Телеметрия. Подключение модулей


signal

Что такое телеметрия, для чего она нужна, как настроить радио модули телеметрии, мы уже разобрались. Осталось произвести подключение бортового модуля к контроллеру APM. Приступим!

 

 

 

 

 

На данный момент мы установили драйвер (адаптер FT232RL USB-COM) на ПК, настроили модули на совместную работу, проверили передачу данных. Теперь необходимо подключить бортовой модуль к контроллеру APM. Рассмотрим разъем порта телеметрии и назначение выводов:

apm-telem-port

Порт телеметрии APM

Вспомним расположение выводов на радио модуле:

Radio-Telemetry-4-conn

Выводы на модуле

Производим подключение по следующей схеме (справедливо для плат APM 2.5.2 и 2.6):

apm-board-conn-telem

Подключение модуля телеметрии к контроллеру

Плюс питания 5В контроллера подключен к +5В модуля, GND к GND, Rx контроллера к Tx модуля, Tx контроллера к Rx модуля. Тут обычно китайцы не путают Rx и Tx, но если в дальнейшем связь не пойдет, то необходимо попробовать поменять их местами.

Далее проверим работу модулей совместно с контроллером. Подаем питание на контроллер, подключаем наземный модуль к ПК. Запускаем Mission Planner, справа, рядом с кнопкой «Connect» выбираем порт и скорость 57600 бод. Запомним для себя, что при подключении с телеметрией — надо выбирать 57600 бод, а при подключении кабелем USB — 115200!

Далее должны увидеть знакомую картинку. Пошел процесс подключения и считывания параметров:

mp-connect

Считывание параметров

Дожидаемся окончания подключения, после чего в MP можно наблюдать все показания, параметры, настройки и т.д. Покрутите плату, чтобы убедиться, что все работает. Если процесс подключения не произошел, то проверьте еще раз правильность подключения проводов и выбора порта и скорости подключения.

Подключение и проверку модулей телеметрии мы выполнили! Двигаемся дальше…

Update 09.09.2014: Подключение и настройку телеметрии надо проводить при питании платы APM от аккумулятора. Когда подключен USB к плате — именно этот порт и используется для связи с ПК и, телеметрия так не заработает.


 
 

Комментариев: 28 - Телеметрия. Подключение модулей

  1. Alex:

    У меня почему что не хочет соединыться через телеметрию. Настройки я считать и записать могу, прошивки одинаковые. Нажимаю в Mission Planer -> Connect и фиг там.
    не подскажите в чём может быть дело ?

    Thumb up 0 Thumb down 0

    • 1. Проверить скорость подключения. В настройках телеметрии должно быть указано 57600, так же эта скорость должна быть выбрана и в MP при подключении.
      2. Проверить «эхо» в Hyper Terminal или в Putty, замкнув TX и RX на бортовом модуле. Если так работает, то искать проблему в настройках.

      Thumb up 0 Thumb down 0

    • Pares:

      Попробуйте настройки, сбросить на стандартные и сразу после этого соединиться, если каналы на модулях будут одинаковые. У меня скорее всего это из-за большого # of Chanel.

      Thumb up 0 Thumb down 0

    • Alex:

      Знаете что оказалось. Китаёзы криворукие когда пояли плату повесили соплю припоя между выводами Rx и Tx на плате APM и замкнули их. Вот поэтому данные не ходили. Кто бы мог подумать что в этом причина.

      Thumb up 2 Thumb down 0

  2. ACE$:

    У меня в убунте апм-планер только делает вид, что зацепляется. На вкладке 3DR radio все работает. Как только переключаю в нормальный режим — сразу молчок.
    С телефона по телеметрии подключается нормально, но чере droid-planner компас откалибровать нельзя.

    Thumb up 0 Thumb down 0

  3. Tado:

    Здравствуйте! Хочу задать вопрос по питанию телеметрии. Бытует мнение, что телемертия создает помехи в линии питания APM и для уменьшения помех впаивают конденсатор. В одном из своих замечательных видео Юлиан обмолвился, что телеметрию хочет запитать от BEC регуляторов. Хотелось бы узнать, что из этого получилось и нужно ли заморачиваться с питанием телеметрии от BEC регулятора или оставить все как есть то ест питание от APM.

    Thumb up 0 Thumb down 0

  4. Con_Go:

    Дааа … 2 часа не мог подключить Mission Planner к контроллеру APM 2.6 через телеметрию… уже вычитал , что новые драйвера не работают с USB мостом (в моем случае применена микросхема CP2102) установка более старых драйверов решила проблему , а связи через телеметрию нет … и тут в конце статьи КРАЙНЕ ВАЖНАЯ информация, что питать контроллер надо не через USB ! ВО! очень странно , т.к. в MP выбирается порт , через который надо коннектиться и все же — запитал контроллер от отдельного ПБ и все — связь установилась. Такое важное предупреждение надо б поставить прям в начале статьи о подключении телеметрии. А так огромное спасибо вообще за весь цикл статей о настройке — очень помогает.

    Thumb up 0 Thumb down 0

  5. Здравствуйте, подскажите пожалуйста, раньше телеметрия работала без нареканий , все хорошо , но после того как я пытался загрузить прошивку 3,3 на квадрокоптер, APM 2.6, то загрузка не удается , хотя все загрузилось , прошивка стоит 3,2,1 , так вот , на квадрокоптере горит зеленый диод на телеметрии и не в какую не может соединиться , скорость в МП 57 600, помогите , а то через юсб запарюсь подключаться (((

    Thumb up 0 Thumb down 1

    • Для APM (не пиксхавк) теперь уж епоследняя прошивка — это 3.2.1. На офф. сайте написано, что 3.3 только для пиксхавка. Думаю ничего плохого у вас не произошло.

      Через USB все нормально работает, а по телеметрии не хочет подключаться?

      Я бы на вашем месте еще разок все сделал бы с нуля пошагово в плане прошивки и загрузчиков и полетной. И пошагово смотреть, после чего заработает.

      Thumb up 0 Thumb down 1

  6. Андрей:

    Здравствуйте, друзья! Нужна помощь. Пытаюсь подключиться к MP через телеметрию Mini 3DR V1.6 433 MHz. На платах видимых повреждений нет. Провода и разъёмы все прозвонил до самых плат — контакты есть. Модули друг-друга видят хорошо. Данные считываются, «эхо» проходит через оба. Прошивки одинаковые (SiK 1.9 on HM-TRP), настройки тоже. Скорость правильная, питание тоже. В диспетчере устройств базовый модуль прописан как Silicon Labs CP210x USB to UART Bridge. Но APM с MP не соединяются и всё тут! Пишет Trying to conect и отсчитывает время до нуля. кстати, при считывании параметров бортовой модуль не всегда откликается. приходится отключать оба и включать снова. Кто знает, что это может быть? Может драйвер? Кстати, у меня Windows 10.

    Thumb up 0 Thumb down 0

    • В какой момент нажимаете кнопку Connect в MP? Нажимать можно после того, как на плате APM проморгаются красный и синий светодиоды, после чего станут моргать реже. С этого момента уже можно пытаться подключиться. А через USB подключение без проблем?

      Thumb up 0 Thumb down 0

      • Андрей:

        Почему-то, при подключении не по USB красный с синим на APM вообще не моргают. просто горит один зелёный сразу. Странно… Значит неправильно запитана APM от аккумулятора?

        Thumb up 0 Thumb down 0

        • При USB моргают, а при телеметрии нет? Такого я еще не видел, да и не должно так быть. Не исключаю тогда всего один вариант — где-то КЗ, которое не дает работать меге 2560.
          А если не мигают в обоих случаях, то читать HOW-TO сначала и прошивать.

          Thumb up 0 Thumb down 0

          • Андрей:

            Я подключил по другому питание от аккумулятора и замигали! 🙂 Но коннектится всё-равно не хочет 🙁 Было подключено «по феншую от Юлиана» к 13-му порту (на боковой шине). А сейчас я подключил к Inputs шине. Замигало, как при подключении по USB. Но не коннектится…

            Thumb up 0 Thumb down 0

            • 13 порт это где датчик напряжения? Тогда без разницы куда подключать, в него или Inputs.
              Может надо подольше подождать, чтобы прошивка стартанула. Может какая нестабильность напряжения у вас. Стабилизатор 3.3В жив?

              А через USB подключение без проблем?

              Thumb up 0 Thumb down 0

            • Почитайте раздел на форуме, вдруг найдете похожую проблему.
              http://forum.apmcopter.ru/forums/mp-conn/

              Thumb up 0 Thumb down 0

  7. Андрей:

    Похоже, я что-то не понимаю в питании APM… Я сделал питание, как в инструкции от Юлиана. Убрал красный провод от модуля питания, оставил все остальные, а питание от отдельного BECа подключал к 13-ой группе контактов на боковой колодке (их там 14 всего). Странно, но APM работает даже без этого отдельного BECа. Питается от 3DR модуля питания даже без красного провода! А вот когда я этот шлейф проводов не подключал, а запитывал только от отдельного BECа на 13-ю группу контактов, на APM горел только зелёный светодиод. Но в любом случае, не коннектится! Ждал долго. По USB нормально, как и раньше. Я на нём уже летал даже! Всё было прошито и настроено по инструкции.

    Thumb up 0 Thumb down 0

  8. Андрей:

    Измерил напряжение: 4,28 вольта. Маловато? При том, что без нагрузки BEC выдаёт 4,97 вольт.

    Thumb up 0 Thumb down 0

    • Конечно маловато. Минимум для нормальной работы 4.5В, но и при них трудно что-то гарантировать.
      Прочитайте нашу статью по питанию в HOW-TO, может что прояснится.

      Thumb up 0 Thumb down 0

      • Андрей:

        Проблему с питанием устранил. Оказывается, это мой «феншуйный» модуль питания такой маломощный почему-то стал, напряжение проседает под нагрузкой. Подключил модуль питания из комплекта и теперь ровно 5 вольт. Но проблема с телеметрией никуда не делась. Я уже всё перепробовал. Даже на другой ОС настраивал (Windows 7). И со старыми драйверами и с самыми свежими. Модули (наземный и бортовой) друг друга видят, настройки с обоих считываются. Но APM никак через них не подключается. Причём, при нажатии в MP на «Connect» на бортовом модуле светодиодный индикатор RX даже разу не мигает. Вообще ничто не мигает, только зелёный горит, мол друг-друга видим. И ещё, когда к APM подключаюсь через терминал MP, не могу команды вводить, потому что там сразу начинают всякие крокозябры быстро вылетать. Но не думаю, что проблема в этом. Ведь на радиомодуле никакие сигналы не проскакивают, при попытке подключиться (судя по светодиодам). Вот я и гадаю, где проблема? Бортовой я не прошивал пока (адаптер ещё не прибыл), но прошивки на обоих одинаковые. Я потому так разобраться тороплюсь, что ещё можно продавцу претензию заявить, если проблема в радиомодулях. Я их всего несколько дней назад получил. Прошу помощи. Мудрых подсказок и советов от сведующих слюдей.

        Thumb up 0 Thumb down 0

        • Если горят оба зеленых, значит модули связались и мал шанс, что связи по радио нет. Вы говорили, что эхо работает.
          Скорости верно выбраны? В модулях должно быть выбрано 57600 и в MP надо выбирать эту же скорость.
          Если у вас была бы FT232RL, а не CP210x, то тут я бы предположил, что попалась сдохшая микросхема. А с CP210x у меня были приколы, что надо было поиграться с драйверами. Вы говорите, что пробовали. Но опять, раз эхо есть, то это не причем.
          Кракозябры могут быть по двум причинам: либо прошивка старше 3.1 и там уже терминала нет и кроме кракозябр ничего не будет, либо выбрана не та скорость (тогда и моргания RX и TX будут не те, а может их и не видно будет).

          Пока думаю, что что-то вы недоговорили и не так сделали.

          Thumb up 0 Thumb down 0

        • Ну и еще один вариант — посмотреть, что на порту телеметрии на APM. Так же проверять работу мультиплексора.

          Thumb up 0 Thumb down 0

          • Андрей:

            Оно заработало! Просто само взяло и заработало внезапно! После того, как я в очередной раз поменял местами проводки RX/TX. После этого подключение сразу пошло. правда, в первый раз очень долго подключалось (минут 5) и потом сильно тормозило. Но во второй раз и далее — уже как по USB, также быстро. Я вообще не понял в чём была проблема! Но рад, что её больше нет. Большое спасибо, за участие и советы!

            Thumb up 0 Thumb down 0

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *